HDLC和PPP学习(一)

HDLC和PPP

高级数据链路控制HDLC(High-Level Data Link Control),二层协议
点对点协议(Point to Point Protocol)
是两种典型的串口封装协议

串行链路的传输方式

异步传输:以帧为单位

同步传输:在固定的时间进行发送和接收数据,需要进行时钟同步。DCE(数据链路设备)DTE(数据终端设备)

HDLC

HDLC帧有三种类型:信息帧(I帧)、监控帧(S帧)、无编号帧(U帧)
信息帧:用于传送数据
监控帧:用于流量控制和差错控制
无编号帧:用于提供对于链路的建立和拆出控制功能

现在使用的HDLC基本上都是非标准的HDLC,没有S帧和U帧。

HDLC启用:

在串口下使用link-protocol hdlc 就可以开启hdlc,使用的是非标准的HDLC

HDLC IP地址借用:

配置好LO口的IP地址后,可以在串口下使用ip address unnumbered interface LoopBack 0来进行配置

HDLC配置:

使用借用LoopBack接口IP进行配置,用OSPF进行动态链路学习。

拓扑如下:

AR1:
#
sysname AR1
#
interface Serial2/0/0
link-protocol hdlc
ip address unnumbered interface LoopBack0
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255
#
ospf 1
area 0.0.0.0
network 1.1.1.1 0.0.0.0
#
return

AR2:
#
sysname AR2
#
interface Serial4/0/0
link-protocol hdlc
ip address unnumbered interface LoopBack0
#
interface LoopBack0
ip address 2.2.2.2 255.255.255.255
#
ospf 1
area 0.0.0.0
network 2.2.2.2 0.0.0.0
#
return

验证:通过OSPF配置后,收敛完成可以相互PING通,证明数据可以交换。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据