PPPoE原理与配置学习

PPPoE协议(PPP over Ethernet)

会话建立过程:

  • 发现阶段,获取对方以外网地址,找到PPPoE服务器,并且协商一个SESSIONID
  • 会话阶段,PPP协商阶段和PPP报文传输阶段。LCP NCP 认证
  • 会话终结阶段,发送报文结束PPPoE会话。

PPPoE协议报文

  • PADI,发现初始报文,以广播形式发出,由Client发出
  • PADO,发现提供报文,单播,由 Server发出
  • PADR,发现请求报文,单播,Client发出
  • PADS,发现会话确认报文,单播,Server发出
  • PADT,发现终止报文

PPPoE配置

分别包含PPPoE的服务器和Client:

拓扑如下:

AR2作为服务器,AR1作为服务端

AR2:
#
sysname AR2
#
ip pool ppp
gateway-list 10.0.0.254
network 10.0.0.0 mask 255.255.255.0
excluded-ip-address 10.0.0.253
dns-list 8.8.8.8
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$'<k]8BF=l$=]6″A*(l\W@YEu%$%$
local-user admin service-type ppp
#
interface Virtual-Template1
ppp authentication-mode chap
remote address pool ppp
ip address 10.0.0.253 255.255.255.0
#
interface GigabitEthernet0/0/0
pppoe-server bind Virtual-Template 1
#
return

AR1:
#
sysname AR1
#
interface Dialer1
link-protocol ppp
ppp chap user admin
ppp chap password cipher %$%$#[xy;P3RwCyNyF*-&0Q$,”rc%$%$
ip address ppp-negotiate
dialer user admin
dialer bundle 1
dialer-group 1
#
dialer-rule
dialer-rule 1 ip permit
#
interface GigabitEthernet0/0/0
pppoe-client dial-bundle-number 1
#
ip route-static 0.0.0.0 0.0.0.0 Dialer1
#
return

验证:可以ping10.0.0.253 可以PING通,使用display ip interface brief 可以查看客户端获取的IP地址。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据