网络地址转换与配置学习

NAT(Network Address Translation)网络地址转换技术

私有网络地址是不能把自己的数据包直接发送到公共网络上的,NAT就可以把私有网络地址的IP报头转换成合法的IP地址。

NAT分为:静态NAT、动态NAT、NAPT

静态NAT

实现了私有地址和公有地址的一对一的转换。
一个公网IP智慧分配给唯一且固定的内网主机。

动态NAT

动态NAT基于地址池来实现私有网络地址和公有网络地址的转换。

NAPT网络端口地址转换

NAPT允许多个内部地址映射到同一个公有地址上的不同端口。达到多对一的形式,节省了公网IP地址紧张的问题。是现在使用最多的NAT技术。

Easy IP

Easy IP允许将多个内部地址映射到网关出接口地址上的不同端口。

NAT服务器

通过配置NAT服务器,可以使用外网用户访问内网服务器。

 

配置练习

Easy IP:Ethernet0/0/1为局域网口,Gi0/0/1为外网接口
#
sysname AR1
#
acl number 2000
rule 5 permit source 192.168.0.0 0.0.0.255
#
interface Ethernet0/0/1
ip address 192.168.0.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 222.222.222.2 255.255.255.0
nat outbound 2000
#
ip route-static 0.0.0.0 0.0.0.0 222.222.222.1

 

地址池方式配置NAT和NAT SERVER:
#
vlan batch 100
#
acl number 2000
rule 5 permit source 192.168.20.0 0.0.0.255
#
interface vlanif100
ip address 192.168.20.1 255.255.255.0
#
interface Ethernet2/0/0
port link-type access
port default vlan 100
#
interface GigabitEthernet3/0/0
ip address 202.169.10.1 255.255.255.0
nat outbound 2000 address-group 1
nat server protocol tcp global 202.169.10.103 www inside 192.168.20.2 8080
#
nat address-group 1 202.169.10.100 202.169.10.200
#
ip route-static 0.0.0.0 0.0.0.0 202.169.10.2

本站文章均为原创,转载请注明文章出处:An的博客,本文地址:http://www.arssra.cn/archives/122.html 如有疑问请留言或者发送邮件至arssra#aliyun.com

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据