OSPF中简单虚链路使用(非骨干区域互联)

  本次是简单的OSPF虚链路使用案例,用于解决非骨干区域互联的问题。
拓扑如下:

  其中,AR2是ABR可以进行跨区域的LSA发送,AR3则不是ABR,无法进行跨区域发送LSA,所以无法通告AR4的路由。在AR2和AR3之间的Area 1中做虚链路,虚链路一直归属骨干区域,并且只能在同一个区域中配置不能跨区域配置,配置如下:
AR2:

#
interface GigabitEthernet0/0/0
 ip address 12.1.1.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 23.1.1.1 255.255.255.0 
#
ospf 1 
 area 0.0.0.0 
  network 12.1.1.0 0.0.0.255 
 area 0.0.0.1 
  network 23.1.1.0 0.0.0.255 
  vlink-peer 23.1.1.2
#

AR3:

#
interface GigabitEthernet0/0/0
 ip address 23.1.1.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 34.1.1.1 255.255.255.0 
#
ospf 1 
 area 0.0.0.1 
  network 23.1.1.0 0.0.0.255 
  vlink-peer 12.1.1.2
 area 0.0.0.2 
  network 34.1.1.0 0.0.0.255 
#

  验证:AR1可以Ping通AR4的lo0接口,也可以通过display ospf 1 lsdb 查看到ar4的链路状态数据库

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据