灵活QinQ基本配置-LAB

按照拓扑,模拟SW2-SW3之间为公网,运行公网VLAN 100和VLAN 200
实验要求:两端的VLAN10和VLAN20,相同VLAN之间可以互相通讯,在公网上分为VLAN10增加VLAN100 Tag,VLAN20增加VLAN200 Tag。

配置如下:
SW4:

sysname SW4
#
vlan batch 10 20
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 20
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 10
#

SW2:

#
sysname SW2
#
vlan batch 100 200
#
interface GigabitEthernet0/0/1
 qinq vlan-translation enable
 port hybrid untagged vlan 100 200
 port vlan-stacking vlan 10 stack-vlan 100
 port vlan-stacking vlan 20 stack-vlan 200
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 100 200
#

SW1:

#
sysname SW1
#
vlan batch 100 200
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 100 200
#

SW3:

#
sysname SW3
#
vlan batch 100 200
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
interface GigabitEthernet0/0/2
 qinq vlan-translation enable
 port hybrid untagged vlan 100 200
 port vlan-stacking vlan 10 stack-vlan 100
 port vlan-stacking vlan 20 stack-vlan 200
#

SW5:

#
sysname SW5
#
vlan batch 10 20
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 10 20
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/3
 port link-type access
 port default vlan 20
#

实验结果:相同VLAN之间可以互相访问,在LSW1上抓包可以看见两层的VLAN Tag。
注意:灵活QinQ只能拥有2层标签,不支持多层标签。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据