PIM SM模型组播实验

实验要求:
使用PIM SM模型
AR3为RP使用LoopBack0口,使用手工指定方式
使用IGP协议OSPF进行内部互联
最终:MCS1运行播放视频,PC1可以使用VCL观看
拓扑如下:

PM-SM 模型组播实验

配置如下:
AR1

#
 sysname AR1
#
multicast routing-enable
#
interface GigabitEthernet0/0/0
 ip address 172.16.0.1 255.255.255.0 
 pim sm
#
interface GigabitEthernet0/0/1
 ip address 10.0.12.1 255.255.255.0 
 pim sm
#
ospf 1 
 area 0.0.0.0 
  network 10.0.12.0 0.0.0.255 
  network 172.16.0.0 0.0.0.255 
#
pim
 static-rp 3.3.3.3
#

AR2:

#
 sysname AR2
multicast routing-enable
#
interface GigabitEthernet0/0/0
 ip address 10.0.12.2 255.255.255.0 
 pim sm
#
interface GigabitEthernet0/0/1
 ip address 10.0.23.2 255.255.255.0 
 pim sm
#
ospf 1 
 area 0.0.0.0 
  network 10.0.12.0 0.0.0.255 
  network 10.0.23.0 0.0.0.255 
#

AR3:

#
 sysname AR3
#
multicast routing-enable
#
interface GigabitEthernet0/0/0
 ip address 10.0.23.3 255.255.255.0 
 pim sm
#
interface GigabitEthernet0/0/1
 ip address 10.0.35.3 255.255.255.0 
 pim sm
#
interface GigabitEthernet0/0/2
 ip address 10.0.34.3 255.255.255.0 
 pim sm
#
interface LoopBack0
 ip address 3.3.3.3 255.255.255.0 
#
ospf 1 
 area 0.0.0.0 
  network 3.3.3.0 0.0.0.255 
  network 10.0.23.0 0.0.0.255 
  network 10.0.34.0 0.0.0.255 
  network 10.0.35.0 0.0.0.255 
#
pim
 static-rp 3.3.3.3
#

AR4:

#
 sysname AR4
#
multicast routing-enable
#
interface GigabitEthernet0/0/0
 ip address 10.0.34.4 255.255.255.0 
 pim sm
#
interface GigabitEthernet0/0/1
 ip address 10.4.56.4 255.255.255.0 
 pim sm
#
ospf 1 
 area 0.0.0.0 
  network 10.0.34.0 0.0.0.255 
  network 10.4.56.0 0.0.0.255 
#
pim
 static-rp 3.3.3.3
#

AR5:

#
 sysname AR5
#
multicast routing-enable
#
interface GigabitEthernet0/0/0
 ip address 10.0.35.5 255.255.255.0 
 pim sm
#
interface GigabitEthernet0/0/1
 ip address 10.4.56.5 255.255.255.0 
 pim sm
#
ospf 1 
 area 0.0.0.0 
  network 10.0.35.0 0.0.0.255 
  network 10.4.56.0 0.0.0.255 
#
pim
 static-rp 3.3.3.3
#

AR6:

#
 sysname AR6
#
multicast routing-enable
#
interface GigabitEthernet0/0/0
 ip address 10.4.56.6 255.255.255.0 
 pim sm
#
interface GigabitEthernet0/0/1
 ip address 192.168.0.6 255.255.255.0 
 pim sm
 igmp enable
#
ospf 1 
 area 0.0.0.0 
  network 10.4.56.0 0.0.0.255 
#
pim
 static-rp 3.3.3.3
#

一些配置要点:
1.AR1为第一跳路由器,需要指定static-RP。AR4、AR5、AR6为RPT树都需要指定static-rp
2.IGMP只需要配置连接客户端的路由器的接口上即可
3.其中AR3、AR4、AR5、AR6存在多条线路,但是组播流量最终只会有一条线路可以通过,并不会负载分担。根据RPF的默认优先级检查 R6通往RP的只有单播路由,根据单播路由优选下一跳IP地址大的规则,AR4的一端组播流量为了避免重复流量会被prune掉。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据