华为Smart Link配置+Flush+Monitor Link

LSW1作为Smart Link设备,配置VLAN 10 20 30 40,GE0/0/1为主端口、GE0/0/2为从端口,做负载分担配置。
其中vlan 10 20 通过GE0/0/1访问,vlan 30 40 通过GE0/0/2访问。

LSW1配置步骤如下:

#
sysname SW1
#
vlan batch 10 20 30 40
#
stp region-configuration
 instance 1 vlan 10 20
 instance 2 vlan 30 40
 active region-configuration
#
interface Vlanif10
 ip address 192.168.10.254 255.255.255.0
#
interface Vlanif20
 ip address 192.168.20.254 255.255.255.0
#
interface Vlanif30
 ip address 192.168.30.254 255.255.255.0
#
interface Vlanif40
 ip address 192.168.40.254 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
 stp disable
#
interface GigabitEthernet0/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
 stp disable
#
smart-link group 1
 load-balance instance 2 slave
 smart-link enable
 port GigabitEthernet0/0/1 master
 port GigabitEthernet0/0/2 slave

SW4上访问SW1后的MAC地址表:

结果表明SW4访问SW1,vlan 10 20 通过GE0/0/1接口发出,vlan 30 40通过GE0/0/2接口发出,已做到负载分担的目的。

当SW1的GE0/0/1接口故障后:SW4访问SW1的情况(中断SW2的GE0/0/2接口模拟故障发生)

SW1无法感知到非直连故障,因此Smart Link接口不会切换,导致流量不通,因为SW1的VLAN 10 20接口GE0/0/1为主接口、GE0/0/2从接口,其中流量通过SW4->SW3->SW1从接口,由于从接口处于阻塞状态,因此无法通讯。

因此需要在SW2、SW3上配置Monitor Link来监控上联,解决非直连故障的情况配置如下:

monitor-link group 1
 port GigabitEthernet0/0/2 uplink
 port GigabitEthernet0/0/1 downlink 1

另外还需要配置控制vlan,当Smart Link发生主从切换后,发出Flush报文,收到Flush报文的设备会更新MAC和ARP表,如果不配置Flush,则需要Smart Link设备主动发起流量触发更新

控制VLAN与Flush配置:

smart-link group 1
  load-balance instance 2 slave
  smart-link enable
  port GigabitEthernet0/0/1 master
  port GigabitEthernet0/0/2 slave
  flush send control-vlan 10 password simple ars
所有设备接口下配置:
 smart-link flush receive control-vlan 10 password simple ars

本站文章均为原创,转载请注明文章出处:An的博客,本文地址:http://www.arssra.cn/archives/488.html 如有疑问请留言或者发送邮件至arssra#aliyun.com

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据