华为VXLAN集中式分布式网关混合实验

其实就是集中式网关和分布式网关配置在一个拓扑上了就是乱了点,其他都差不多,本次做练习。直接上配置

Spine:

!Software Version V200R005C10SPC607B607
!Last configuration was updated at 2020-09-10 23:51:47+00:00
#
sysname Spine
#
evpn-overlay enable
#
bridge-domain 10
 vxlan vni 10010
 evpn
  route-distinguisher 100:10010
  vpn-target 100:10010 export-extcommunity
  vpn-target 100:10010 import-extcommunity
#
bridge-domain 20
 vxlan vni 10020
 evpn
  route-distinguisher 100:10020
  vpn-target 100:10020 export-extcommunity
  vpn-target 100:10020 import-extcommunity
#
interface Vbdif10
 ip address 192.168.10.254 255.255.255.0
#
interface Vbdif20
 ip address 192.168.20.254 255.255.255.0
#
interface GE1/0/0
 undo portswitch
 undo shutdown
 ip address 10.0.12.1 255.255.255.0
#
interface GE1/0/1
 undo portswitch
 undo shutdown
 ip address 10.0.13.1 255.255.255.0
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.255
#
interface Nve1
 source 1.1.1.1
 vni 10010 head-end peer-list protocol bgp
 vni 10020 head-end peer-list protocol bgp
#
bgp 100
 peer 2.2.2.2 as-number 100
 peer 2.2.2.2 connect-interface LoopBack0
 peer 3.3.3.3 as-number 100
 peer 3.3.3.3 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo peer 2.2.2.2 enable
  undo peer 3.3.3.3 enable
 #
 l2vpn-family evpn
  undo policy vpn-target
  peer 2.2.2.2 enable
  peer 2.2.2.2 reflect-client
  peer 3.3.3.3 enable
  peer 3.3.3.3 reflect-client
#
ospf 1 router-id 1.1.1.1
 area 0.0.0.0
  network 1.1.1.1 0.0.0.0
  network 10.0.12.0 0.0.0.255
  network 10.0.13.0 0.0.0.255
#

leaf:

sysname Leaf_1
#
evpn-overlay enable
#
ip vpn-instance A
 ipv4-family
  route-distinguisher 100:5100
  vpn-target 100:5100 export-extcommunity evpn
  vpn-target 100:5100 import-extcommunity evpn
 vxlan vni 5100
#
bridge-domain 10
 vxlan vni 10010
 evpn
  route-distinguisher 100:10010
  vpn-target 100:10010 export-extcommunity
  vpn-target 100:10010 import-extcommunity
#
bridge-domain 10100
 vxlan vni 10100
 evpn
  route-distinguisher 100:10100
  vpn-target 100:10100 export-extcommunity
  vpn-target 100:5100 export-extcommunity
  vpn-target 100:10100 import-extcommunity
#
interface Vbdif10100
 ip binding vpn-instance A
 ip address 192.168.100.254 255.255.255.0
 mac-address 0000-5e00-0301
 vxlan anycast-gateway enable
 arp collect host enable
#
interface GE1/0/0.10 mode l2
 encapsulation dot1q vid 10
 bridge-domain 10
#
interface GE1/0/0.100 mode l2
 encapsulation dot1q vid 100
 bridge-domain 10100
#
interface GE1/0/1
 undo portswitch
 undo shutdown
 ip address 10.0.12.2 255.255.255.0
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.255
#
interface Nve1
 source 2.2.2.2
 vni 10010 head-end peer-list protocol bgp
 vni 10100 head-end peer-list protocol bgp
#
bgp 100
 peer 1.1.1.1 as-number 100
 peer 1.1.1.1 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo peer 1.1.1.1 enable
 #
 l2vpn-family evpn
  policy vpn-target
  peer 1.1.1.1 enable
#
ospf 1 router-id 2.2.2.2
 area 0.0.0.0
  network 2.2.2.2 0.0.0.0
  network 10.0.12.0 0.0.0.255
#

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据