RIP距离矢量路由协议学习(一)

RIP(路由信息协议)

基于距离矢量算法的协议,使用跳数来衡量到达目的网络的距离。主要应用于小型网络中。

最大支持的有效跳数是15跳。

动态路由协议

IGP协议:内部网关协议,用于企业内部网络。包括:OSPF、ISIS、RIP等

EGP协议:外部网关协议,用于ISP之间互联使用。包括:BGP协议。

动态路由选择算法的步骤:

  • 向其他路由器发送路由信息
  • 接收其他路由器的路由信息
  • 计算出到每个网络中的最优路径,生成路由表
  • 如果拓扑发生变化及时作出反应,重新生成路由表,并且把拓扑变化的信息传递给其他路由器。

当路由表稳定下来后,路由器会有特定的周期发送路由表(30s)。

简单RIP配置

拓扑如下:

PC1=192.168.10.1 PC2=192.168.30.1

配置如下:

AR1:
#
sysname AR1
#
interface GigabitEthernet0/0/0
ip address 192.168.20.1 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
ip address 192.168.10.254 255.255.255.0
#
rip 1
network 192.168.10.0
network 192.168.20.0
#
return

AR2:
#
sysname AR2
#
interface GigabitEthernet0/0/0
ip address 192.168.20.2 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
ip address 192.168.30.254 255.255.255.0
#
rip 1
network 192.168.30.0
network 192.168.20.0
#
return

验证配置:PC1 PING PC2 等收敛结束后可以ping通。

RIP计时器

更新定时器(Update timer):当定时器超时后,则会发送更新报文。30s
老化定时器(Age timer):如果在老化时间内,没有收到其相邻的路由器发来的更新报文,则认为该路由不可达。180s
垃圾收集定时器(Garbage-collect timer):在垃圾收集时间内,不可达的路由器依旧没有发送更新报文,则将从路由表中彻底删除。120s
抑制定时器(Supperss timer):当收到路由更新报文后,其cost值为16,对应路由器进入抑制状态,启动抑制定时器。为了防止路由震荡,在定时器超时之前,即使收到更新路由信息小于cost16的更新也不接收。华为路由器中不使用这个定时器,时间为0s

RIP度量

RIP使用路由跳来衡量路由距离。
直连网络跳数为0,发送更新时会加1。
超过15跳的网络为不可达。

RIPv1和RIPv2

RIPv1:

  • 有类别路由协议,不支持VLSM(可变长子网)和CIDR。
  • 广播形式发送报文
  • 不支持认证

RIPv2:

  • 无类别路由协议,支持VLSM和CIDR、路由聚合。
  • 广播和组播(224.0.0.9)形式发送报文
  • 支持明文认证和MD5加密认证

在RIP模式下使用命令:version 1 和 version 2 就可以改变RIP的版本了。默认为1。

RIPv2认证

认证是在接口模式下配置的使用命令:rip authentication-mode md5 nonstandard cipher 123 1 设置md5加密,密码为123 keyID=1

本站文章均为原创,转载请注明文章出处:An的博客,本文地址:http://www.arssra.cn/archives/59.html 如有疑问请留言或者发送邮件至arssra#aliyun.com

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据