一种VXLAN特殊场景的通讯(两端VNI不一致的场景)实验

场景:两端租户的RT一致,但是L3 VNI不一致,L2 VNI也不一致的场景。可以进行通讯。主要的配置内容在Leaf,配置如下:

Leaf_1(CE2):

#
sysname Leaf_1
#
evpn-overlay enable
#
ip vpn-instance OS_A          //配置租户
 ipv4-family
  route-distinguisher 1:5000
  vpn-target 1:5000 export-extcommunity evpn
  vpn-target 1:5000 import-extcommunity evpn
 vxlan vni 5000             //配置L3 VNI
#
bridge-domain 10
 vxlan vni 10010          //配置L2 VNI
 evpn
  route-distinguisher 1:10010
  vpn-target 1:10010 export-extcommunity
  vpn-target 1:5000 export-extcommunity   //与租户ERT交叉
  vpn-target 1:10010 import-extcommunity
#
interface Vbdif10
 ip binding vpn-instance OS_A
 ip address 192.168.10.254 255.255.255.0
 arp collect host enable      //用于探测主机上线(ENSP中的PC没效果,因为开机不会发送免费ARP)
#
interface GE1/0/0.10 mode l2
 encapsulation dot1q vid 10
 bridge-domain 10
#
interface GE1/0/1
 undo portswitch
 undo shutdown
 ip address 10.0.12.2 255.255.255.252
#
interface LoopBack0
 ip address 2.2.2.2 255.255.255.255
#
interface Nve1
 source 2.2.2.2
 vni 10010 head-end peer-list protocol bgp  //配置头端复制列表,本拓扑中可以不配置因为 VNI 10010只有一台设备
#
interface NULL0
#
bgp 100
 router-id 2.2.2.2
 peer 1.1.1.1 as-number 100
 peer 1.1.1.1 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo peer 1.1.1.1 enable
 #
 l2vpn-family evpn
  policy vpn-target
  peer 1.1.1.1 enable
  peer 1.1.1.1 advertise irb  //让BGP EVPN通告IRB路由
#
ospf 1 router-id 2.2.2.2
 area 0.0.0.0
  network 2.2.2.2 0.0.0.0
  network 10.0.12.0 0.0.0.3
#
总结:Leaf_2与Leaf_1类似配置,按图中配置RT即可通讯,其中证明控制路由进入路由表或者MAC表的非VNI,而是IP VRF和MAC VRF中的RT值。其中VXLAN报文中的VXLAN VNI的值的作用是去查找相应VNI的VRF的作用。

此场景非现网场景,现网一般不进行这样的操作,只是试验用于校验学习而已。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据