GARP与GVRP学习

GARP

通用属性注册协议,为处于同一个交换网内的交换机之间提供了一种分发、传播、注册的手段

GARP本身是一种协议规范,并不作为一个实体在交换机中存在。目前GARP的应用主流是GVRP和GMRP。

GARP报文结构

GARP采用IEEE802.3 Ethernet封装形式,目的MAC地址为多播MAC地址:01-80-C2-00-00-21。

GARP的属性事件为0-5具体如下:

  • 0:代表LeaveAll事件
  • 1:代表JoinEmpty事件
  • 2:代表JoinIn事件
  • 3:代表LeaveEmpty事件
  • 4:代表LeaveIn事件
  • 5:代表Empty事件

当交换机希望其他交换机注册自己的属性信息,则会发送Join信息。
当交换机希望其他交换机注销自己的属性信息,则会发送Leave信息。
交换机发送LeaveAll消息,用来注销所有的属性。

GVRP

是GARP的一种具体应用或实现,主线用于维护设备动态VLAN属性。

GVRP用来进行注册和注销VLAN属性的协议

注册模式

交换机端口默认为Normal模式,允许动态和静态VLAN注册,同时发送动态和静态的VLAN声明消息。

Fixed模式,不允许动态VLAN在端口上注册和注销,至允许静态VLAN

Forbidden模式,不允许动态vlan在端口上进行注册,同时删除端口上除VLAN1外的所有VLAN

GVPR配置

拓扑如下:

PC1=192.168.10.1/24  PC2=192.168.10.2/24

LSW1配置:
#
sysname LSW1
#
vlan batch 10 to 13
#
gvrp
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 10
#
interface GigabitEthernet0/0/24
port link-type trunk
port trunk allow-pass vlan 2 to 4094
gvrp
#
return

LSW2:

#
sysname LSW2
#
vlan batch 10 to 13
#
gvrp
#
interface GigabitEthernet0/0/24
port link-type trunk
port trunk allow-pass vlan 2 to 4094
gvrp
#
interface GigabitEthernet0/0/23
port link-type trunk
port trunk allow-pass vlan 2 to 4094
gvrp
#
return

LSW3:
#
sysname LSW3
#
vlan batch 10 to 13
#
gvrp
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 10
#
interface GigabitEthernet0/0/24
port link-type trunk
port trunk allow-pass vlan 2 to 4094
gvrp
#
return

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据