VLAN间路由学习

不同的VLAN在二层交换机之间是不能进行相互通讯的,只有通过路由器或者三成交换机来实现。使用三层交换机的时候,可以为每个vlan创建一个VLANIF接口作为网关。

 

单臂路由

将交换机和路由器之间的链路配置为Trunk链路,并且在路由器上创建子接口支持VLAN路由。

单臂路由配置:
要点:配置单臂路由的时候需要在子接口配置dot1q termination vid VLANID 和 arp broadcast enable 
要求:

  • PC1、PC3在VLAN10
  • PC2、PC4在VLAN20
  • PC1和PC3互通,PC2和PC4互通
  • VLAN10和VLAN20互通
  • LSW1使用hybrid类型接口、LSW2使用Trunk接口作为互通接口

拓扑如下:

配置如下:

PC1=192.168.10.1
PC2=192.168.20.1
PC3=192.168.10.2
PC4=192.168.20.2
AR Gi0/0/0.1=192.168.10.254/24  Gi0/0/0.2=192.168.20.254/24

AR1:
#
sysname AR1
#
vlan batch 10 20
#
interface GigabitEthernet0/0/0
#
interface GigabitEthernet0/0/0.1
dot1q termination vid 10
ip address 192.168.10.254 255.255.255.0
arp broadcast enable
#
interface GigabitEthernet0/0/0.2
dot1q termination vid 20
ip address 192.168.20.254 255.255.255.0
arp broadcast enable
#
return

LSW1:
#
sysname LSW1
#
vlan batch 10 20
#
interface Ethernet0/0/1
port link-type access
port default vlan 10
#
interface Ethernet0/0/2
port link-type access
port default vlan 20
#
interface Ethernet0/0/21
port hybrid tagged vlan 10 20
#
interface Ethernet0/0/22
port hybrid tagged vlan 10 20
#
return

LSW2:
#
sysname LSW2
#
vlan batch 10 20
#
interface Ethernet0/0/1
port link-type access
port default vlan 10
#
interface Ethernet0/0/2
port link-type access
port default vlan 20
#
interface Ethernet0/0/22
port link-type trunk
port trunk allow-pass vlan 10 20
#
return

配置验证,VLAN10和VLAN20之间可以相互通讯。

本站文章均为原创,转载请注明文章出处:An的博客,本文地址:http://www.arssra.cn/archives/98.html 如有疑问请留言或者发送邮件至arssra#aliyun.com

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据