Vxlan&EVPN分布式网关实验-华为

拓扑如下:

环境说明:IP地址规划:Leaf1 VTEP = 1.1.1.1/32(Loopback0地址),Leaf2 VTEP = 2.2.2.2/32(Loopback0地址),互联地址随意,使用回环地址建立BGP evpn邻居关系,vlan10客户机可以访问vlan20,vlan20内部之间可以正常访问。

配置如下(这里只放leaf配置了,Spine配置很简单就是BGP evpn):

这里缺少一个配置就是多活网关的MAC要配置为一样的地址

#
sysname Leaf_1
#
evpn-overlay enable
#
ip vpn-instance A
 ipv4-family
  route-distinguisher 1:1
  vpn-target 11:11 export-extcommunity evpn
  vpn-target 11:11 import-extcommunity evpn
 vxlan vni 1000
#
bridge-domain 10010
 vxlan vni 10010
 evpn
  route-distinguisher 10:10
  vpn-target 10:10 export-extcommunity
  vpn-target 11:11 export-extcommunity
  vpn-target 10:10 import-extcommunity
#
bridge-domain 10020
 vxlan vni 10020
 evpn
  route-distinguisher 20:20
  vpn-target 20:20 export-extcommunity
  vpn-target 11:11 export-extcommunity
  vpn-target 20:20 import-extcommunity
#
interface Vbdif10010
 ip binding vpn-instance A
 ip address 192.168.10.254 255.255.255.0
 vxlan anycast-gateway enable
 arp collect host enable
#
interface Vbdif10020
 ip binding vpn-instance A
 ip address 192.168.20.254 255.255.255.0
 vxlan anycast-gateway enable
 arp collect host enable
#
interface GE1/0/0
 undo portswitch
 undo shutdown
 ip address 10.0.13.1 255.255.255.0
#
interface GE1/0/1.10 mode l2
 encapsulation dot1q vid 10
 bridge-domain 10010
#
interface GE1/0/1.20 mode l2
 encapsulation dot1q vid 20
 bridge-domain 10020
#
interface LoopBack0
 ip address 1.1.1.1 255.255.255.255
#
interface Nve1
 source 1.1.1.1
 vni 10010 head-end peer-list protocol bgp
 vni 10020 head-end peer-list protocol bgp
#
bgp 100
 peer 3.3.3.3 as-number 100
 peer 3.3.3.3 connect-interface LoopBack0
 #
 ipv4-family unicast
  undo peer 3.3.3.3 enable
 #
 l2vpn-family evpn
  policy vpn-target
  peer 3.3.3.3 enable
  peer 3.3.3.3 advertise irb
#
ospf 1
 area 0.0.0.0
  network 1.1.1.1 0.0.0.0
  network 10.0.13.1 0.0.0.0
#

实验结果:

本站文章均为原创,转载请注明文章出处:An的博客,本文地址:http://www.arssra.cn/archives/473.html 如有疑问请留言或者发送邮件至arssra#aliyun.com

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据