H3C交换机新版M-lag配置

场景说明:传统组网,交换机1、交换机2组成M-lag系统,与交换机3形成跨设备链路聚合,并且作为网关、根桥。这种技术H3C之前叫做DRNI,目前新版系统中已经改名为M-lag。

交换机1配置:

#
 sysname A-H1
#
ip vpn-instance Keepalive  //配置Keepalive使用的VRF,非必要,建议将Keepalive独立出来,除非复用三层逃生,逃生可以考虑子接口
#
vlan 1
#
 stp instance 0 root primary
 stp global enable
#
interface Bridge-Aggregation11  //配置与SW3的跨设备聚合口
 link-aggregation mode dynamic
 port m-lag group 11
#
interface Bridge-Aggregation1024 //配置Peer-link接口
 port link-type trunk
 port trunk permit vlan all
 link-aggregation mode dynamic
 port m-lag peer-link 1 //配置了该命令后,Peer-link接口会自动变为trunk然后允许所有vlan通过
#
interface Route-Aggregation1024 //配置Keepalive接口,可以是三层单接口,建议采用聚合口,增加冗余性
 ip binding vpn-instance Keepalive
 ip address 1.1.1.1 255.255.255.252
 link-aggregation mode dynamic
#
interface Vlan-interface1 //配置双活网关
 ip address 192.168.10.254 255.255.255.0
 mac-address 7e20-ab68-0100 //双活网关中,同一个网关MAC地址必须一致
 ipv6 address 240E::FFFF:FFFF/96
#
interface GigabitEthernet1/0/1
 port link-mode bridge
 combo enable fiber
 port link-aggregation group 11
#
interface FortyGigE1/0/53
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1024
#
interface FortyGigE1/0/54
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1024
#
interface Ten-GigabitEthernet1/0/51
 port link-mode route
 combo enable fiber
 port link-aggregation group 1024
#
interface Ten-GigabitEthernet1/0/52
 port link-mode route
 combo enable fiber
 port link-aggregation group 1024
#
 m-lag mad exclude interface Route-Aggregation1024 //配置M-LAG的Peer-link链路中断后,Keepalive链路为非阻断场景,如果不配置,则会造成二次故障场景产生,当故障设备恢复后会导致M-lag系统来回震荡。
 m-lag restore-delay 180 //当M-lag系统分裂后,重新恢复,备机会等待180s才会将业务接口UP,避免转发黑洞
 m-lag system-mac 7e20-ab68-0100 //配置M-lag系统的全局MAC,主要用于LACP的system-id和stp的桥ID
 m-lag system-number 1 //配置m-lag系统中的角色,主设备配置为1,备设备配置为2
 m-lag system-priority 4096 //配置m-lag中LACP的优先级
 m-lag standalone enable delay 600 //开启DR设备独立工作功能,仅Peer-link和Keeaplive同时故障时生效,故障后,设备会形成双主,但是与其他设备组成的M-LAG接口lacp会采用独立的system-id与对端进行lacp协商,最终只会有一台设备协商成功,防止了故障场景的转发问题。
 m-lag keepalive ip destination 1.1.1.2 source 1.1.1.1 vpn-instance Keepalive //配置keepalive链路并指定相关的vpn-instance
#
return

故障场景测试:关闭Peer-link链路模拟链路故障

结论:当Peer-link故障后,MAD功能触发,将M-LAG备系统的业务接口全部关闭防止双主场景出现。

故障场景测试:当Peer-link链路和Keepalive链路同时故障

结论:可以看到M-LAG独立工作模式生效,两台设备恢复了自身的system-id,导致交换机3仅能与其中一台设备进行聚合,流量会转发给M-LAG主设备,但是这种场景仅限于二层场景,如果M-LAG系统上联的设备是三层并且是负载场景,那么依旧会有流量转发到M-LAG备设备从而造成转发黑洞的产生。

故障场景:Keepalive链路故障

结论:当仅有Keepalive故障的场景时,不会影响系统转发,功能依旧正常,但是没有避免m-lag分裂后的故障处理了。


			

发表评论

您的电子邮箱地址不会被公开。

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据