华为VXLAN DCI之Segment VXLAN不同AS三层互通

场景说明:AS 100为DC1、AS200是DC2,在两个DC中有一个租户A,分别有PC1、PC2两台设备,PC1地址为192.168.10.2、PC2地址为192.168.20.1,现在租户A的两台设备需要通讯。场景为分布式网关场景,网关位于各自DC内的Leaf交换机上。
本次采用Segment vxlan的方式进行配置,主要是进行三层互通,整个DCI会建立三个隧道,分别为Leaf-1<->DCI-Leaf-1之间、DCI-Leaf-1 <-> DCI-Leaf-2之间、DCI-Leaf-2 <-> Leaf-2之间建立隧道。
控制平面:以PC1为例,当Leaf-1感知到PC1上线后,会生成一条EVPN TYPE2路由,通告给本AS内的RR,也就是Spine-1,当Spine-1收到该路由后将路由反射给DCI-Leaf-1,DCI-Leaf-1收到该路由后,会将该BGP EVPN路由打上重生标记,并且重生发送给DCI-Leaf-2,并且将下一跳改为自己的VTEP地址,DCI-Leaf-2收到路由后也会对该路由打上重生标记,并且重生发送给本AS内的RR Spine-2,并且将下一跳修改为DCI-Leaf-2的VTEP地址,Spine-2会将路由反射给Leaf-2,Leaf-2收到该路由后会在租户A的路由表中生成一条iBGP的32位主机路由,下一跳为DCI-Leaf-2的VTEP地址。
控制平面传递路由的时候出方向路由会携带ERT,收到路由后会根据本端配置的IRT进行路由交叉,交叉成功后才会在租户的路由表中生成路由。本次实验租户下配置的ERT和IRT全部一致。并且在BGP EVPN传递路由的时候会在MP_REACH_NLRI属性中携带L2 VNI和L3 VNI。
本次主要配置在DCI-Leaf上,其余Spine、Leaf配置均在以前文章内有。

DCI-Leaf-1配置:

#
sysname DCI-Leaf-1
#
evpn-overlay enable
#
evpn
#
ip vpn-instance A   //配置租户A的L3 VNI和RD、RT值
 ipv4-family
  route-distinguisher 10:1000
  vpn-target 10:1000 export-extcommunity
  vpn-target 10:1000 export-extcommunity evpn
  vpn-target 10:1000 import-extcommunity
  vpn-target 10:1000 import-extcommunity evpn
 vxlan vni 1000
#
interface MEth0/0/0
 undo shutdown
#
interface GE1/0/0
 undo portswitch
 undo shutdown
 ip address 100.0.12.1 255.255.255.252
#
interface GE1/0/9
 undo portswitch
 undo shutdown
 ip address 10.0.11.1 255.255.255.252
#
interface LoopBack0
 ip address 1.1.1.3 255.255.255.255
#
interface Nve1  //配置VTEP地址为1.1.1.3
 source 1.1.1.3
#
bgp 100
 peer 1.1.1.1 as-number 100
 peer 1.1.1.1 connect-interface LoopBack0
 peer 2.2.2.3 as-number 200
 peer 2.2.2.3 ebgp-max-hop 2
 peer 2.2.2.3 connect-interface LoopBack0
 #
 ipv4-family unicast
  dampening
  undo peer 1.1.1.1 enable
  undo peer 2.2.2.3 enable
 #
 l2vpn-family evpn
  policy vpn-target
  peer 1.1.1.1 enable
  peer 1.1.1.1 advertise irb  //通告IRB型路由
  peer 1.1.1.1 import reoriginate //对收到的BGP EVPN路由打上重生标记
  peer 1.1.1.1 advertise route-reoriginated evpn mac-ip //对BGP EVPN的2类路由进行重生
  peer 1.1.1.1 advertise route-reoriginated evpn ip  //对BGP EVPN的5类路由进行重生
  peer 2.2.2.3 enable
  peer 2.2.2.3 advertise irb
  peer 2.2.2.3 import reoriginate
  peer 2.2.2.3 advertise route-reoriginated evpn mac-ip
  peer 2.2.2.3 advertise route-reoriginated evpn ip
#
ospf 1
 area 0.0.0.0
  network 1.1.1.3 0.0.0.0
  network 10.0.11.0 0.0.0.3
#
ip route-static 2.2.2.3 255.255.255.255 100.0.12.2
#
return

实验结果:

抓包:

从抓包看来,PC1访问PC2携带的VXLAN VNI只有租户的L3 VNI,因为是跨网段访问,非二层访问。

路由查看:

由此可见,路由是 通过MAC-IP型路由进行传递的,非5类路由进行传递

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据