H3C VXLAN EVPN DCI互联同租户不同vxlan二层互联

场景说明:同一个租户在两个DC之间分别租了机器,为了满足虚拟机漂移、二层互访的场景,地址设计上在同一个网段,因此需要不同DC之间进行同租户的二层互访。

DCI-Leaf配置:

#
 sysname DCI-Leaf-1
#
ospf 1
 area 0.0.0.0
  network 1.1.1.2 0.0.0.0
  network 10.0.11.0 0.0.0.3
#
 l2vpn enable //开启2层VPN能力,使能vxlan
#
vsi vxlan10010  //配置二层vxlan及映射关系
 vxlan 10010
 evpn encapsulation vxlan
  route-distinguisher 10:10010
  vpn-target 10:10010 export-extcommunity
  vpn-target 10:10010 import-extcommunity
  mapping vni 20000 //将vxlan10010映射为20000
#
vsi vxlan20000 //配置映射后的vxlan 20000,用于DCI-Leaf之间自动建立隧道
 vxlan 20000
 evpn encapsulation vxlan
  route-distinguisher 10:20000
  vpn-target 10:20000 export-extcommunity
  vpn-target 10:20000 import-extcommunity
#
interface LoopBack0
 ip address 1.1.1.2 255.255.255.255
#
interface FortyGigE1/0/53
 port link-mode route
 ip address 10.0.11.1 255.255.255.252
#
interface FortyGigE1/0/54
 port link-mode route
 ip address 10.0.12.1 255.255.255.252
 dci enable
#
bgp 100
 peer 1.1.1.1 as-number 100
 peer 1.1.1.1 connect-interface LoopBack0
 peer 2.2.2.2 as-number 200
 peer 2.2.2.2 connect-interface LoopBack0
 peer 2.2.2.2 ebgp-max-hop 2
 #
 address-family l2vpn evpn
  undo policy vpn-target
  peer 1.1.1.1 enable
  peer 1.1.1.1 next-hop-local
  peer 1.1.1.1 reflect-client
  peer 2.2.2.2 enable
  peer 2.2.2.2 router-mac-local
#
 ip route-static 2.2.2.2 32 10.0.12.2
#
return

实验结果:

两端模拟虚机的交换机可以互访,接下来看DCI之间抓包情况:

由此可见,中间DCI之间传输报文的时候,是封装vlxan2000的,原始数据报文中的源目地址不变。适用于H3C VXLAN DCI互联配置

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据