H3C交换机DRNI配置(M-LAG)

场景说明:S1和S2组成DRNI(M-LAG)系统,与S3组成一个跨设备动态聚合组

S1配置:

#
 sysname S1
#
interface Bridge-Aggregation1
 link-aggregation mode dynamic
 port drni group 1           //指定接口为drni组
#
interface Bridge-Aggregation1024
 port link-type trunk
 port trunk permit vlan all
 link-aggregation mode dynamic
 port drni intra-portal-port 1 //指定该接口为IPP端口,类似华为、锐捷的Peer-link
#
interface Route-Aggregation1024
 ip address 1.1.1.1 255.255.255.252
 link-aggregation mode dynamic
#
interface FortyGigE1/0/53
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1024
#
interface FortyGigE1/0/54
 port link-mode bridge
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1024
#
interface Ten-GigabitEthernet1/0/51
 port link-mode route
 combo enable fiber
 port link-aggregation group 1024
#
interface Ten-GigabitEthernet1/0/52
 port link-mode route
 combo enable fiber
 port link-aggregation group 1024
#
 drni role priority 120   //配置DRNI的角色优先级,默认32768,越小越优先类似STP选举,一致则选择MAC地址小的
 drni system-number 1     //配置DRNI系统编号只有1和2,一组DNRI不能相同
 drni keepalive ip destination 1.1.1.2 source 1.1.1.1 //配置DRNI Keepalive的地址
 drni mad exclude interface Route-Aggregation1024 //配置IPP链路中断导致双主时不会阻塞掉keepalive端口
 drni system-mac 4e71-4b43-0100 //配置DRNI的系统MAC,一组DRNI要配置一致,这里的MAC主要是LACP时使用的
#
return

S2的配置与S1差不多,有一点就是drni system-priority这个配置,建议采用默认32768,如果要配置的话,一组DRNI必须一致,这里不是选举主从的优先级,这里是LACP中端口的优先级。另外交换机不会自己选举system-mac,需要手动配置

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据